Difference between revisions of "Browser"

From SmartWiki
Jump to: navigation, search
(Internet Browser Support on PC/Desktop Devices)
(For Windows, macOS or Linux)
 
(8 intermediate revisions by the same user not shown)
Line 1: Line 1:
__TOC__
+
=Supported Web Browsers=
 
+
The following web browsers are supported by SmartSimple. For the best experience we suggest using the latest version of Chrome, Firefox or Safari.
==General==
 
SmartSimple is accessed through popular Internet browsers.
 
 
 
 
 
 
 
==Internet Browser Support on PC/Desktop Devices==
 
The following browsers are currently supported:
 
 
 
* '''Chrome''': two most recent versions* [http://www.google.com/chrome/ download]
 
* '''Firefox''': two most recent versions* [http://www.mozilla.org/ download]
 
* '''Safari''': two most recent versions* [http://www.apple.com/safari/ download]
 
* '''Internet Explorer''' [http://windows.microsoft.com/en-IE/internet-explorer/download-ie download]: version 11.0 and higher
 
* '''Microsoft Edge''': two most recent versions* [https://www.microsoft.com/en-ca/download/details.aspx?id=48126 download]
 
 
 
 
 
All browsers listed above are supported on all '''Windows''', '''OS X''' and '''Linux''' Operating Systems that are explicitly stated as supported by the individual browser manufacturer.
 
  
 +
==For Windows, macOS or Linux==
 +
{| class="wikitable"
 +
|-
 +
||Chrome
 +
||two most recent versions https://www.google.com/chrome/
 +
|-
 +
||Firefox
 +
||two most recent versions https://www.mozilla.org/en-US/
 +
|-
 +
||Safari
 +
||two most recent versions https://www.apple.com/safari/
 +
|-
 +
||Microsoft Edge
 +
||two most recent versions
 +
|-
 +
||Microsoft Internet Explorer
 +
||version 11.0 †
 +
|}
  
 +
† Some SmartSimple features may not be available in IE11.
  
 
+
==For iOS and Android (mobile)==
===Unsupported browser message===
 
If the Browser being used is not supported then user will be presented with a message on the login page to inform them of this fact. The exact wording of the alert is shown below.
 
 
 
'''''We have detected that you are using an unsupported browser. If you continue to use this browser, the site may not display properly. To view a list of supported browsers, please visit http://wiki.smartsimple.com/wiki/Browser.'''''
 
 
 
 
 
User should upgrade to a supported version of the browser.
 
 
 
==Internet Browser Support on Mobile Devices==
 
SmartSimple supports native browsers on iOS and Android. Platform support for mobile devices extends to Arcadia and Arcadia X interfaces only. The Classic interface is not supported on mobile devices.
 
 
 
 
{| class="wikitable"
 
{| class="wikitable"
|-
 
||'''Mobile Operating System'''
 
||'''Supported Browser'''
 
 
|-
 
|-
 
||iOS
 
||iOS
Line 43: Line 32:
 
||Chrome
 
||Chrome
 
|}
 
|}
 +
 
==Notes==
 
==Notes==
* '''Note 1:''' As of Jan. 12, 2016, only the most recent version of Internet Explorer, available for the Windows operating system in use, will be supported. See table above. This is reflective of [https://support.microsoft.com/en-us/gp/microsoft-internet-explorer/ Microsoft's browser version support policy]. SmartSimple will also be providing support for the version previous to the most current version available (Internet Explorer 10).
+
* Internet Explorer '''Compatibility Mode''' should '''NOT''' be enabled for access to SmartSimple, as some items such icons displayed on buttons (Font Awesome) and other aspects of the system will not render correctly.
* '''Note 2:''' Internet Explorer compatibility should not be enabled for access to SmartSimple as some items such icons displayed on buttons (Font Awesome) will not be displayed correctly. For additional information on disabling Internet Explorer compatibility mode see [http://kb.mit.edu/confluence/display/istcontrib/How+to+change+your+setting+for+Compatibility+mode+for+Internet+Explorer Disable Compatibility Mode]
+
* By the two most recent versions, we are referring to the current version published by the manufacturer excluding beta releases, and the previous version.
* '''Note 3:''' Firefox, Chrome, Safari and Microsoft Edge support applies to the current version published by the manufacturer '''excluding beta releases''', and the previous version.
+
* The SmartSimple mobile app supports Android version 6 or later and iOS version 9.3 or later.
 
 
 
 
  
[[Category:Glossary]]
+
[[Category:Interface]]

Latest revision as of 11:43, 6 November 2019

Supported Web Browsers

The following web browsers are supported by SmartSimple. For the best experience we suggest using the latest version of Chrome, Firefox or Safari.

For Windows, macOS or Linux

Chrome two most recent versions https://www.google.com/chrome/
Firefox two most recent versions https://www.mozilla.org/en-US/
Safari two most recent versions https://www.apple.com/safari/
Microsoft Edge two most recent versions
Microsoft Internet Explorer version 11.0 †

† Some SmartSimple features may not be available in IE11.

For iOS and Android (mobile)

iOS Safari
Android Chrome

Notes

  • Internet Explorer Compatibility Mode should NOT be enabled for access to SmartSimple, as some items such icons displayed on buttons (Font Awesome) and other aspects of the system will not render correctly.
  • By the two most recent versions, we are referring to the current version published by the manufacturer excluding beta releases, and the previous version.
  • The SmartSimple mobile app supports Android version 6 or later and iOS version 9.3 or later.